Skip to content

Algoritmos prontos

Para rodar esses arquivos, você precisa ter instalado o programa “VisualG”, que interpreta e executa algoritmos.  Você pode baixa-lo clicando aqui.

Algoritmo diz se você é maior ou menor de idade:

// Função : diz se voce é maior ou menor de idade
// Autor : Thaysa
// Data : 17/4/2008
// Seção de Declarações
var
idade1 : real
nome : caractere
inicio
// Seção de comandos
escreva(“Qual é o seu nome? “)
leia (nome)
escreva(“Digite sua idade : “)
leia (idade1)
se idade1 <=18 entao
escreva(nome, ” você é menor de idade”)
senao
escreva(nome, ” você é maior de idade”)
fimse
fimalgoritmo

Algoritmo calcula peso de bois:

// Função : calcula peso entre bois
// Autor : Thaysa
// Data : 24/5/2009
// Seção de Declarações
// Seção de Declarações
var

menor, maior, peso: real
i, cod_menor, cod_maior: inteiro

inicio
// Seção de Comandos

limpatela

menor<-10000
maior<-0

para i de 1 ate 9 faca

escreva(“Digite o peso do boi”,i,”: “)
leia(peso)
se (peso
menor<-peso
cod_menor<-i fimse se (peso>maior)entao
maior<-peso
cod_maior<-i
fimse

fimpara

escreval(“O boi”,cod_menor,”com”,menor,” Kg foi o mais leve”)
escreval(“O boi”,cod_maior,”com”,maior,” Kg foi o mais pesado”)

fimalgoritmo

Algoritmo lê um nome e diz se corresponde ao seu:

// Função : le um nome do teclado e diz sé igual ao seu nome.
// Autor : THAYSA
// Data : 1/5/2009
// Seção de Declarações
var
nome : caractere

inicio
// Seção de Comandos
Escreva (“Digite seu nome: “)
leia (nome)

se (nome) = “Thaysa” entao
escreva (“Correto”)
senao
escreva (“Incorreto”)
fimse
fimalgoritmo

Algoritmo identifica o tipo de triângulo:

// Função : triangulos
// Autor : Thaysa
// Data : 13/5/2009
// Seção de Declarações
var
a,b,c : real
inicio
// Seção de Comandos
escreva(“entre com o valor de a: “)
leia(a)
escreva(“entre com o valor de b: “)
leia(b)
escreva(“entre com o valor de c: “)
leia(c)

se (A
escreval(“Estes valores formam um triangulo”)

se (A=B) e (B=C) entao
escreva (“Triangulo Equilátero”)
senao
se (A=B) ou (B=C) ou (A=C) entao
escreva (“Triângulo Isósceles”)
senao
escreva (“Triangulo Escaleno”)
fimse
fimse
senao
escreva (“Estes valores não formam um triângulo”)
fimse

fimalgoritmo

Algoritmo calcula IMC:

// Função : calcula IMC
// Autor : Thaysa
// Data : 29/4/2009
// Seção de Declarações
var
numimc, peso, altura, somapesos : numerico

inicio
// Seção de Comandos

Escreval (“Entre com o seu peso: “)
leia (peso)
Escreval (“Entre com a sua altura: “)
leia (altura)

somapesos <- (peso/altura^2)
escreval (“seu imc é”, somapesos)

fimalgoritmo

Algoritmo lê três numeros reais e diz se ele é maior que a soma dos outros dois:

// Função : Lê 3 numeros reais e verifica se o primeiro é maior que a soma dos outros dois
// Autor : Thaysa
// Data : 29/4/2009
// Seção de Declarações
var
num1, num2, num3, total : numerico

inicio
// Seção de Comandos
Escreva (“Digite um número : “)
leia (num1)
Escreva (“Digite outro número : “)
leia (num2)
Escreva (“Digite mais um número : “)
leia (num3)

total <- (num2+num3)
se total <= num1 entao
escreva (” Maior “)
senao
escreva (” Menor “)
fimse
fimalgoritmo

Algoritmo que descobre a sua idade:

// Função : descobre idade
// Autor : Thaysa
// Data : 24/5/2009
// Seção de Declarações
var
nome : caractere
idade, ano1, ano2 : numerico
inicio
// Seção de Comandos
repita
escreval (” digite o nome: “)
leia (nome)
escreval (“digite o ano de nascimento: “)
leia (ano1)
escreval (“digite o ano atual: “)
leia (ano2)
idade <-ano2 – ano1
escreval (nome, idade)
escreva
ate idade=25
fimalgoritmo

Algoritmo que diz quanto você gastou comprando cigarros:

// Função : diz quanto você gastou comprando cigarros
// Autor : Thaysa
// Data : 28/04/2009
// Seção de Declarações
var
anos, cigdia : numerico
cart, gasto : real
inicio
// Seção de Comandos

Escreva (“N° de cigarros fumados por dia”)
leia (numcigdia)
Escreva (“Quantidade de anos que você fuma”)
leia (numeanos)
Escreva (“Preço do maço de cigarros”)
leia (precocart)

gastototal<- ((anos*365)*cigdia)*cart/20
Escreva (“Você ja gastou um total de R$ “)
Escreva (gasto)
Escreva (” em maço de cigarros!”)
fimalgoritmo

Algoritmo calcula média entre alunos:

// Função : calcula media
// Autor : Thaysa
// Data : 17/6/2009
// Seção de Declarações
var
idade, Cont_H, Cont_M, idade_H, idade_M : inteiro
sexo : caractere
inicio
idade 0 faca

escreva (“Digite o Sexo, [H] ou [M]: “)
leia(sexo)
escreva (“Digite a idade: “)
leia(idade)

se sexo=”H” entao
idade_H <- idade_H + idade
Cont_H <- Cont_H + 1
senao
se sexo="M" entao
idade_M <- idade_M + idade
Cont_M <- Cont_M + 1
fimse
fimse
fimenquanto

escreval ("A media dos alunos de Sexo H é ", Idade_H/Cont_H)
escreva ("A media dos alunos de Sexo M é ", Idade_M/Cont_M)
fimalgoritmo

Algoritmo calcula média de um aluno e dá resultado:

// Função : calcula media e da resultado
// Autor : Thaysa
// Data : 13/4/2008
// Seção de Declarações
var
n1, n2, n3, M : numerico
nome : caractere
inicio
// Seção de Comandos
escreva (“Qual seu nome? “)
leia (nome)
escreva (“Digite a primeira nota “)
Leia (n1)

escreva (“Digite a segunda nota “)
Leia (n2)

escreva (“Digite a terceira nota “)
Leia (n3)

Escreva (“As notas são”, n1)
Escreva (“,”, n2)
Escreva (” e”, n3)

M =7 entao
escreval (“Condição do aluno: Aprovado”)
senao
escreval (“Condição do aluno: Reprovado”)
fimse
Escreva (“”)
fimalgoritmo

Algoritmo lê um número e diz seu sucessor:

// Função : le numero e diz sucessor
// Autor : Thaysa
// Data : 28/04/2009
// Seção de Declarações
var
num, total : numerico
inicio
// Seção de Comandos
escreva (“Digite um numero: “)
leia (num)
total <- (num+1)
escreva (total)
escreva (" é o seu sucessor")
fimalgoritmo

Algoritmo lê três números e põe em ordem crescente:

// Função : ler 3 numeros e por em ordem crescente!
// Autor :
// Data : 19/05/2009
// Seção de Declarações
var
a,b,c : numerico
inicio
// Seção de Comandos
leia (a,b,c)
se (a=b) ou (b=c) entao
escreva (“Alguns ou todos os numeros sao iguais “)
senao

se (a<b) e (a<c) entao//a é menor
se (b<c) entao
escreva (a,b,c)
senao escreva (a,c,b)
fimse;
fimse;

se (b<a) e (b<c) entao//b é menor
se (a<c) entao
escreva (b,a,c)
senao escreva (b,c,a)
fimse
fimse

se (c<a) e (c<b) entao//c é menor
se (a<b) entao
escreva (c,a,b)
senao escreva (c,b,a)
fimse
fimse

fimse
fimalgoritmo

Algoritmo lê número e acrescenta 30% sobre ele:

// Função : acrescenta 30% a um numero
// Autor : Thaysa
// Data : 07/05/2009
// Seção de Declarações
var
num, percent: numerico
inicio
// Seção de Comandos
escreva (“Digite um Valor “)
leia (num)
percent <- (num*(30/100))
escreva ("Seu valor é ",percent)

fimalgoritmo

One Comment

Deixe um Comentário
  1. Raizdecimal / Jan 17 2010 12:56 am

    Que interessante! Eu fiz uns programinhas em VisuAlg também.

Deixe uma Resposta

Preencha os seus detalhes abaixo ou clique num ícone para iniciar sessão:

Logótipo da WordPress.com

Está a comentar usando a sua conta WordPress.com Terminar Sessão / Alterar )

Imagem do Twitter

Está a comentar usando a sua conta Twitter Terminar Sessão / Alterar )

Facebook photo

Está a comentar usando a sua conta Facebook Terminar Sessão / Alterar )

Google+ photo

Está a comentar usando a sua conta Google+ Terminar Sessão / Alterar )

Connecting to %s

%d bloggers like this: